It's our great honour to announce the Industry’s First VHBR CCID reader - VHBR Dual interface smart card reader vR504. It is able to support the world’s fastest ePassports.

To celebrate the new product release, there is Special Discount for New Registered Members in our store.
- Get $20.00 OFF instantly for smart card reader vR504, R502 and bR301

Come to get the readers now!

[Pyapdu tool] Can't select applet

JCIDE related questions and answers.

Moderators: product, kuafu

adam452
Posts: 2
Joined: Wed Sep 06, 2017 2:43 am
Points: 42
Contact:

[Pyapdu tool] Can't select applet

Postby adam452 » Wed Sep 06, 2017 2:55 am

I use Pyapdu tool to download cap file. download is OK, install is OK. But select not OK

Image

this is code
Image

Please help me. Thanks

User avatar
mabel
Posts: 219
Joined: Mon May 18, 2015 3:09 am
Points: 1541
Contact:

Re: [Pyapdu tool] Can't select applet

Postby mabel » Wed Sep 06, 2017 10:43 pm

1. Would you tell us your card model?

2. Is your pyApdutool version the latest one?

BTW, I have tested your code with pyApdutool on my computer. It can work without any problem.

adam452
Posts: 2
Joined: Wed Sep 06, 2017 2:43 am
Points: 42
Contact:

Re: [Pyapdu tool] Can't select applet

Postby adam452 » Wed Sep 06, 2017 10:48 pm

Card model : ACOSJ
reader: ACR38U-A4
Pyapdu tool download from https://javacardos.com/tools/ ver:1.0

User avatar
mabel
Posts: 219
Joined: Mon May 18, 2015 3:09 am
Points: 1541
Contact:

Re: [Pyapdu tool] Can't select applet

Postby mabel » Thu Sep 07, 2017 1:30 am

It seems that your pyApdutool is not the latest version. You may need to re-download this tool. My pyApdutool(also downloaded from here) is v1.1

pyapdutool-v1.1.png


In my mind, there were some bugs in the old version of pyApdutool.
You do not have the required permissions to view the files attached to this post. Please login first.


Return to “Questions & Answers”

Who is online

Users browsing this forum: No registered users and 2 guests

JavaCard OS : Disclaimer