Christmas is coming soon! To thank for the support from all our dear customers, Christmas promotional activity is going on in JavaCardOS online store. For more activities details, please check this post.

FluffyPGPApplet Instructions & Applet Source Code

Open source implementation of the OpenPGP smart card version 2.0 on a java card.

Moderator: Ellisun

User avatar
JavaCardOS
Posts: 265
Joined: Thu Apr 30, 2015 12:00 pm
Points :2313
Contact:

FluffyPGPApplet Instructions & Applet Source Code

Post by JavaCardOS » Wed Jun 17, 2015 1:12 am

This Open source applet implements the GPG Card v 2.0.1 specification without using secure channels or Global Platform for portability.

Support
• 2048 bit RSA keys
• RSA Key import (CRT format)
• Random number generation
• Private DOs

Limitations
• No extended APDU support.
• Supports only 2048 bit CRT RSA keys (1024 is too short and most cards don't support 4096 bits)
• No secure messaging support.
• No support for the cardholder certificate (DO 7F21).
• Readability was favored over code size.
• Will not run on cards with an APDU buffer smaller than 256 + 5 bytes.

For more information about this Applet, please see the following file.
Note:
The Applet has been successfully compiled in JCIDE, and can be directly used after downloading.
You can also get source codes from GitHub or SourceForge (GPL3).
You do not have the required permissions to view the files attached to this post. Please login first.
Last edited by JavaCardOS on Fri Jan 08, 2016 1:59 am, edited 6 times in total.

nobody2015
Posts: 15
Joined: Wed Aug 19, 2015 3:11 am
Points :48
Contact:

Re: FluffyPGPApplet

Post by nobody2015 » Wed Dec 02, 2015 8:28 am

In Github,
Card Requirements

Java card version 2.2.2 (2.2.1 might work but it is untested)
2048 bit RSA key support
Global platform 2.1.1 or above to use the loading scripts.


For the version of JavaCard and GlobalPlatform, this applet has these limitations?

User avatar
horse dream
Posts: 76
Joined: Thu May 21, 2015 11:48 pm
Points :136
Contact:

Re: FluffyPGPApplet

Post by horse dream » Sat Dec 05, 2015 2:20 am

This applet is no particularly limited for JavaCard and GP version.

If your Java Card supported the version of JavaCard and GP versions is lower, At the time of building applet, you can select the lower version of the API and convertor.

Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 1 guest

JavaCard OS : Disclaimer