We are very excited to launch a brand new product - LibSC Reader Kit.

LibSC Reader Kit developed by JavaCardOS Technologies is implemented based on Arduino hardware platform and this kit provides simple universal card reader's functions.

And this time we have launched two kinds of development kit - LibSC Reader Kit and LibSC Reader Kit pro.

Please check this page for more release details.

Problem about BitcoinWallet

JavaCard Applet Development Related Questions and Answers.
AmigoJack
Posts: 17
Joined: Thu Nov 19, 2015 4:56 am
Points: 85
Contact:

Problem about BitcoinWallet

Postby AmigoJack » Thu May 18, 2017 11:15 pm

I downloaded BitcoinWallet from this topic. When I debug this applet in JCIDE, it returns error below:
Does anybody know how to solve this problem? Thanks.

com.ledger.wallet [May 18,2017 15:03:31]
"C:\JavaCardKit\JDK\bin\javac" -g -deprecation -target 1.2 -source 1.2 -J-Duser.language=en -d "F:\Code\BitcoinWallet\bin" -encoding GBK -classpath .;F:\Code\BITCOI~1\bin;"C:\JavaCardKit\SDK\Tools\JCIDE\lib\java_card_kit\2_2_1\lib\api.jar";"C:\JavaCardKit\SDK\Tools\JCIDE\lib\java_card_kit\2_2_1\lib\converter.jar";"C:\JavaCardKit\SDK\Tools\JCIDE\lib\java_card_kit\2_2_1\lib\offcardverifier.jar";"C:\JavaCardKit\SDK\Tools\JCIDE\lib\JavaCos_kit\gp\gp211\lib\gp211.jar";"C:\JavaCardKit\SDK\Tools\JCIDE\lib\JavaCos_kit\sm\2012\lib\sm.jar"; F:\Code\BITCOI~1\src\com\ledger\wallet\AddressUtils.java F:\Code\BITCOI~1\src\com\ledger\wallet\Base58.java F:\Code\BITCOI~1\src\com\ledger\wallet\BCDUtils.java F:\Code\BITCOI~1\src\com\ledger\wallet\Bip32.java F:\Code\BITCOI~1\src\com\ledger\wallet\Bip32Cache.java F:\Code\BITCOI~1\src\com\ledger\wallet\Crypto.java F:\Code\BITCOI~1\src\com\ledger\wallet\GenericBEHelper.java F:\Code\BITCOI~1\src\com\ledger\wallet\HmacSha512.java F:\Code\BITCOI~1\src\com\ledger\wallet\Keycard.java F:\Code\BITCOI~1\src\com\ledger\wallet\LedgerWalletApplet.java F:\Code\BITCOI~1\src\com\ledger\wallet\LWNFCForumApplet.java F:\Code\BITCOI~1\src\com\ledger\wallet\MathMod256.java F:\Code\BITCOI~1\src\com\ledger\wallet\ProprietaryAPI.java F:\Code\BITCOI~1\src\com\ledger\wallet\Ripemd160.java F:\Code\BITCOI~1\src\com\ledger\wallet\Secp256k1.java F:\Code\BITCOI~1\src\com\ledger\wallet\SHA512.java F:\Code\BITCOI~1\src\com\ledger\wallet\TC.java F:\Code\BITCOI~1\src\com\ledger\wallet\Transaction.java F:\Code\BITCOI~1\src\com\ledger\wallet\Uint32Helper.java F:\Code\BITCOI~1\src\com\ledger\wallet\Uint64Helper.java
F:\Code\BITCOI~1\src\com\ledger\wallet\LWNFCForumApplet.java:61: annotations are not supported in -source 1.2
(use -source 5 or higher to enable annotations)
@Override
^
1 error


User avatar
UNKNwYSHSA
Posts: 628
Joined: Thu May 21, 2015 4:05 am
Points: 2967
Contact:

Re: Problem about BitcoinWallet

Postby UNKNwYSHSA » Thu May 18, 2017 11:32 pm

From the log:
-target 1.2 -source 1.2


Set the target and source to 1.5 or above 1.5. The Annotation Type @override is since 1.5.

Set it in the dialog "Javac options":
javac-target-source-1.5-override-annotation.png
You do not have the required permissions to view the files attached to this post. Please login first.
sense and simplicity

AmigoJack
Posts: 17
Joined: Thu Nov 19, 2015 4:56 am
Points: 85
Contact:

Re: Problem about BitcoinWallet

Postby AmigoJack » Fri May 19, 2017 2:24 am

It works! It works! Thank you very much, UNKNwYSHSA.


Return to “Questions & Answers”

Who is online

Users browsing this forum: No registered users and 6 guests

JavaCard OS : Disclaimer